আজকের তারিখ: 4 August, 2020

Mikrotik Non Payment Reminder PPPOE/Hotspot

Ad

Dear ISP,
if you want to remind your non payment user you can do this with some simple steps, you just have to make a PPPOE profile with custom adress list.

things we have to do:

  • create Blocked user adress list,
  • Create ip pool for payment profile,
  • create new pppoe profile with blocked address list,
  • change payment message,

Create Blocked user adresslist :

Mikrotik Payment Reminder

Mikrotik Payment Reminder

Copy and paste this to mikrotik terminal

/ip firewall filter
add action=accept chain=forward comment="User Blocked Non Paid" disabled=no dst-port=53 protocol=udp src-address-list=Blocked
add action=accept chain=forward disabled=no dst-address-list=Blocked dst-port=53 protocol=udp
add action=drop chain=forward disabled=no src-address-list=Blocked
 
/ip firewall nat
add action=redirect chain=dstnat comment="Blocked User" disabled=no dst-port=80 protocol=tcp src-address-list=Blocked to-ports=8081
 
/ip proxy
set always-from-cache=no cache-administrator=webmaster cache-hit-dscp=4 cache-on-disk=no enabled=yes max-cache-size=none max-client-connections=600 max-fresh-time=3d max-server-connections=600 parent-proxy=0.0.0.0 parent-proxy-port=0 port=8081 serialize-connections=no src-address=0.0.0.0
 
/ip proxy access
add action=allow disabled=no dst-host=protiva.net dst-port=80 local-port=8081
add action=deny disabled=no dst-port=80 local-port=8081 redirect-to=protiva.net/payment/payment.html

Create IP Pool for payment profile

Copy and paste this to mikrotik terminal

/ip pool add name=Blocked ranges=192.168.99.2-192.168.99.254

Create Non payment profile

now go to PPP > Profile > Add
name it Payment and select Local adress / Remote Adress / Adress List = Blocked
and set dns 8.8.8.8,
set speed limit to 1M

Mikrotit non payment reminder

Mikrotit non payment reminder

Done, now change profile of pppoe user on secret, and see the magic (after changing user profile please disconnect it from secret list)

Change payment message

if you want to change notice message of mikrotik not payment user
go to IP > Webproxy > Access ,
change redirect url of your own HTML page 

need help for creating non payment user ? just comment bellow i will reply as soon i can,

Share

2 Comments

মন্তব্য করুন

আপনার ই-মেইল এ্যাড্রেস প্রকাশিত হবে না। * চিহ্নিত বিষয়গুলো আবশ্যক।

//graizoah.com/afu.php?zoneid=3422763